www.valterborsato.it

Applicare la Funzione SE.ERRORE per gestire i codici di errore di Excel

La Funzione SE.ERRORE permette la restituzione di un messaggio personalizzato quando una Formula restituisce come risultato un codice di errore. Il codice di errore può essere sostituito da un testo, un numero oppure una stringa vuota.

In questo tutorial viene trattata la Funzione logica SE.ERRORE spiegandone sintassi e possibilità di applicazione.

Sintassi della Funzione Logica SE.ERRORE

La Funzione SE.ERRORE (nome inglese della Funzione IFERROR) permette di definire un messaggio personalizzato qualora una formula restituisce un codice di errore; in caso contrario, restituisce il risultato della formula.
Sintassi della Funzione:
=SE.ERRORE(valore;se_errore)
nella quale:
valore rappresenta il valore di riferimento o la formula da valutare nella quale verificare la presenza di un errore.
se_errore valore da restituire qualora venisse rilevato un errore.
Nella Funzione SE.ERRORE vengono considerati i seguenti tipi di errore: #N/D, #VALORE!, #RIF!, #DIV/0!, #NUM!, #NOME? o #NULLO!

Quando applicare la Funzione SE.ERRORE nei Fogli di lavoro di Excel

Una delle situazioni più frequenti di applicazione della Funzione SE.ERROE riguarda Fogli Excel con delle Funzioni impostate, ma momentaneamente vuoti dei dati di ricerca che dovranno essere successivamente inseriti.
Questo tipo di impostazione restituisce da parte di Excel dei messaggi di errore che rimarranno visibili fino a quando le celle (a cui fanno riferimento gli argomenti delle Funzioni) non verranno compilate.
La parziale compilazione delle celle del documento potrà ovviamente lasciare sul foglio di lavoro una parte di questi messaggi,

 . Excel | Applicare la Funzione SE.ERRORE per gestire messaggi di Errore.

Esempio: La tabella rappresentata nell'immagine di cui sopra, tramite Funzioni CERCA.VERT, cerca in un intervallo denominato lista (presente in un altro Foglio di lavoro) la descrizione e il prezzo di un prodotto in riferimento ad uno specifico codice.
Oltre alle funzioni di ricerca, nell'ultima colonna, una formula totalizza l'importo parziale di riga e alla fine una Funzione SOMMA determina il totale complessivo.
In questo esempio, fino a quando non viene inserito un codice di riferimento nella colonna B, molti messaggi #N/D (dato non disponibile) restano visibili sul Foglio di lavoro.
Attenzione, mentre nelle colonne C ed E il messaggio di errore di Excel è solamente una "fastidiosa" informazione di testo, nella colonna F è un problema anche per il calcolo, poichè la presenza di un'informazione testuale rende impossibile la totalizzazione dei valori nella cella F10.

Esempio di applicaizone della Funzione SE.ERRORE

Nel caso delle formule presenti nell'immagine sottostante, è possibile pensare a due soluzioni distinte.
Nel caso della colonna C (Descrizione) si vuole produrre un messaggio di testo che indichi all'operatore la necessità di inserire un codice di riferimento.
Nel caso delle colonne E e F (prezzo totale) si vuole semplicemente nascondere il messaggio di errore.

Excel | La funzione SE.ERRORE

Sostituire un codice di errore con la Funzione SE.ERRORE

Nella caso della colonna C per restituire la scritta "inserisci un codice" basterà anteporre al Cerca Verticale la funzione SE.ERRORE una volta chiusa la parentesi che racchiude il CERCA.VERT va inserito il ";" e successivamente fra doppi apici il testo con il quale si vuole sostituire il messaggio di errore #N/D
=SE.ERRORE(CERCA.VERT(B3;lista;2;1);"inserisci un codice")

Eliminare un codice di errore con la Funzione SE.ERRORE

La Funzione SE.ERRORE, può servire per cancellare qualsiasi codice di un eventuale errore.
Per ottenere questo risultato va semplicemente definito vuoto (senza nessun contenuto) il valore all'interno dei doppi apici. Questa soluzione è opportuna ad esempio nella colonna F (dell'esempio di cui sopra), nella quale la funzione di sommatoria verticale non può essere calcolata, poichè nell'intervallo di somma sono presenti dei testi e non informazioni numeriche.

=SE.ERRORE(D3*E3;"")

Excel | Sostuire il messaggio di errore con uno spazo vuoto espresso con doppi apici

Tabella riassuntiva dei codici di errore di Excel

 Messaggio di errore Descrizione
#DIV/0! Messaggio di errore visualizzato quando un numero viene diviso per zero o per una cella che non contiene un valore.
#NOME? La Funzione impostata contiene un nome che Excel non riconosce. (tipicamente errore nello scrivere il nome di una funzione)
#N/D Questo messaggio indica che i valori ricercati non sono disponibili.  (Ad esempio è frequente la restituzione di questo errore nella funzione cerca verticale).
#NULLO! Nullo, viene visualizzato quando si specifica un'intersezione di due aree che però non si intersecano.
#NUM! Questo messaggio indica un problema in un valore. Esempio un numero positivo dove dovrebbe esserci un numero negativo.
#RIF! Riferimento ad un cella non valida.
#VALORE! La formula include operatori o argomenti errati.

Argomenti correlati

:: Per un approfondimento sui messaggi di errore si rimanda a: Excel: Codici e Messaggi di ERRORE
:: Il Codice di errore #N/D!: Applicare applicare la Funzione SE.NON.DISP di excel
:: Gestire il codice di errore nelle stampe e nelle Funzioni di Excel: Come Gestire il codice di errore #N/D nei Fogli di Excel

Indice Generale Argomenti: EXCEL

[Valter Borsato: dicembre - 2016 | Ultimo aggiornamento 09/01/2021]