www.valterborsato.it

Sorteggiare in Excel testi e numeri

Utilizzare la Funzione CASUALE di Excel per sorteggiare da un elenco di voci un valore.
L'applicazione di questa particolare Funzione di Excel trova forse la sua principale applicazione nel gioco ad esempio per decretare ad estrazione il vincitore fra un lista di persone. Oppure estrarre dei valori numerici riferibili ad un gioco quale il lotto o ad un semplice lancio virtuale di dadi.
Le funzioni di Excel che vengono presentate in questa nota sono  CASUALE.TRA; CASUALE e INDICE.

La Funzione CASUALE.TRA

La Funzione CASUALE.TRA restituisce un numero intero casuale compreso in un determinato range. La sintassi della funzione è la seguente
=CASUALE.TRA(Minore;Maggiore)
Gli operatori  Minore e Maggiore (obbligatori) indicano rispettivamente il valore minimo e massimo entro i quali estrarre casualmente il numero.

La Funzione CASUALE.TRA in parte sostituisce la precedente versione CASUALE (tuttora presente anche nella versione 2013 di Excel).
La Funzione CASUALE restituisce un numero compreso fra 0 e 1 il cui risultato DEVE essere moltiplicato per una determinata scala valore es. 10 (per ottenere un range da 1 a 10)
CASUALE deve essere preceduto dalla Funzione INT se si desidera la restituzione di un numero intero.

Utilizzare la Funzione CASUALE.TRA per una estrazione numerica

Si ipotizza la necessità di estrarre un valore compreso fra 1 e 6 (esempio il lancio di un dado) oppure fra 1 e 90 se si volesse emulare un sorteggio del gioco del lotto.

La Funzione da applicare sarebbe la seguente = CASUALE.TRA(1;6)  oppure =CASUALE.TRA(1;90)

Excel: utilizzare la Funzione CASUALE per produrre sorteggi di testi o estrazioni numeriche

:: Per ricalcolare la Funzione è sufficiente premere il tasto Funzione F9

Giocare con Excel

Nel dubbio su quali numeri giocare ad un estrazione del superenalotto, si potrebbe chiedere aiuto alla fortuna e impostare nel Foglio di lavoro di Excel una serie di 6 celle con inserita la Funzione  = CASUALE.TRA(1;90)
................ Non resta che premere  F9 e .................. BUONA FORTUNA

Excel: utilizzare la Funzione CASUALE per produrre sorteggi di testi o estrazioni numeriche

Sorteggiare un valore testuale o numerico da un elenco

Se si dispone sul foglio di lavoro di Excel di un elenco di nomi, è possibile sorteggiare uno di questi valori utilizzando assieme le Funzioni INDICE e CASUALE.TRA

La Funzione INDICE permette di trovare i dati all'interno di una tabella nel punto di intersezione di una riga specifica e una colonna.
Nell'esempio a lato INDICE riferisce come colonna l'intervallo B2:B9, con la funzione CASUALE.TRA viene determinato un riferimento di riga qualsiasi della tabella compresa fra la 1 e la 8.

=INDICE(B2:B9;CASUALE.TRA(1;8))

Excel sorteggiare valori | Utilizzare la Funzione INDICE e la Funzione CASUALE.TRA

Anche in questo caso, premendo il tasto Funzione F9 è possibile procedere ad una nuova estrazione di dati

Indice argomenti

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT