www.valterborsato.it

Lavorare con le Funzioni e Formule di Excel

Le Formule di Excel e le Funzioni di Excel, spesso confuse come significato, sono in realtà due diverse e distinte operazioni di calcolo. Le Formule sono delle equazioni che eseguono operazioni sui valori presenti sul foglio di lavoro di Excel. Sono pertanto delle istruzioni di calcolo e possono ad esempio eseguire operazioni utilizzando nella loro espressione gli operatori matematici. Le Funzioni rappresentano invece degli operatori matematici predefiniti, e sono caratterizzate da un'istruzione precisa e definita dal nome stesso della funzione, Esempio: MEDIA; SOMMA etc.

Regole impostazione Formule Excel - Operatori matematici di base

Gli operatori aritmetici di base
Gli operatori matematici fondamentali presenti nel tastierino numerico della tastiera del PC specificano il tipo di operazione che si possono eseguire sui valori di una formula.
La barra "/" rappresenta la divisione; l'asterisco "*" la moltiplicazione e il simbolo più "+" e meno "-" la somma e sottrazione.
E' possibile utilizzare altri operatori ad esempio il carattere accento circonflesso "^" permette di elevare a potenza un numero. E' anche possibile impostare da subito la percentualizzazione con il carattere "%"

Le Formule Excel | Le Funzioni di Excel: regola impostazione formule e funzioni

Excel esegue una Funzione nell'ordine in cui è stata scritta leggendola da sinistra verso destra. Vi sono però delle precedenze matematica tipiche delle equazioni matematiche, pertanto moltiplicazioni e divisioni vengono eseguite prima di somme e sottrazioni. Per modificare questo ordine è possibile utilizzare le parentesi (In Excel solo rotonde) con diversi possibili livelli di inclusione.
:: In Excel non esistono parentesi quadrate o graffe, ma solo rotonde che possono essere incluse l'una nell'altra.

Alcuni esempi di impostazioni delle Formule Excel

Le Formule Excel | Le Funzioni di Excel: esempio formule Excel

Le Funzioni di Excel

Le Funzioni rappresentano degli operatori matematici predefiniti che eseguono calcoli utilizzando valori specifici (argomenti) definiti in un particolare ordine o struttura. Nell'imputare una Funzione  in primo luogo si deve indicare il nome della Funzione che si intende eseguire e successivamente elencare gli argomenti della Funzione inseriti tra parentesi e separati con il punto virgola.
Esempio:
=Nome_Funzione (Argomenti)

Gli operatori di riferimento utilizzati nelle Funzioni

All'interno delle Funzioni di Excel, è spesso necessario fare riferimento a intervalli di celle più o meno ampi che contengono i valori da calcolare. Per indicare gli intervalli di celle o le singole celle Excel utilizza gli operatori di riferimento. Nella tabella sotto illustrata viene esemplificato l'utilizzo degli operatori di riferimento  due punti ":"e del punto e virgola ";"

Le Formule Excel | operatori di riferimeno formule e funzioni

Ovviamente gli operatori di riferimento possono essere utilizzati in forma mista. E' possibile ad esempio calcolare tutte le celle comprese in un intervallo e contemporaneamente le celle presenti in altre parti del Foglio di lavoro di Excel.
Nell'esempio illustrato nella sottostante immagine vengono considerate possibili combinazioni degli operatori di riferimento all'interno di due Funzioni MEDIA e SOMMA.

Le Funzioni di Excel: SOMMA e MEDIA

La Funzione SOMMA rappresenta sicuramente la Funzione di Excel maggiormente utilizzata nei fogli di lavoro.
La sintassi della Funzione è la seguente:
=SOMMA(Num1;Num2.....)

Dove gli argomenti Num1;Num2... rappresentano i riferimenti alle celle o all'area del foglio contenente i valori da sommare.
Per approfondire la Funzione SOMMA: La Funzione SOMMA | Impostare formule di sommatoria in Excel

Le Formule e le Funzioni di Excel | La Funzione SOMMA

Nell'esempio di sommatoria proposto nell'immagine la Funzione =SOMMA(B2:B6) poteva essere indicata ad Excel anche nelle seguenti sintassi
=SOMMA(B2;B3;B4;B5;B6) oppure =B2+B3+B4+B5+B6

La Funzione MEDIA, restituisce la media aritmetica dei valori.
La sintassi della Funzione è la seguente:
=MEDIA(num1;[num2];...)
Dove per num1, num2,.. si intendono i riferimenti alle serie numeriche da analizzare.
Per approfondire la Funzione MEDIA: Medie aritmetiche in Excel, Le Funzioni MEDIA; MEDIA.SE; MEDIA.PIÙ.SE

Le Formule e le Funzioni di Excel | La Funzione SOMMA

 

Indice argomenti

Indice argomenti correlati: Excel base

01 - Introduzione ad Excel: La Barra Multifunzione e la Barra della Formula
02 - Imputare testi e numeri: Formattazioni numeriche e introduzione alle Formule e Funzioni
03 - Formule e Funzioni:Le Formule e le Funzioni di Excel (introduzione e nozioni di base)
04 - Imputare Formule e Funzioni: Le Formule di sommatoria in Excel e l'utilizzo della Funzione SOMMA
05 - Funzioni: Utilizzare Inserisci Funzione e Argomenti Funzione

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT