www.valterborsato.it

Come applicare la Funzione logica SE di Excel

La Funzione logica SE risulta sicuramente una delle Funzioni maggiormente applicate nei Fogli di lavoro di Excel.
La Funzione Logica SE permette di valutare una condizione (test_logico) e definire due possibili azioni qualora questa condizione risultasse VERA oppure FALSA.
Si tratta della Funzione logica più semplice e maggiormente applicata in Excel, e in questo tutorial andremo ad analizzare la sintassi e diverse possibili impostazioni.

Contenuti del tutorial: La Funzione logica SE di Excel

[1] - La Funzione SE - introduzione e sintassi
[2] - Funzione SE di Excel: gli operatori logici di confronto
[3] - Applicare la Funzione SE - due semplici esempi di applicazione
[4] - Applicare la Funzione SE - inserire Formule negli argomenti vero, falso
[5] - Applicare la Funzione SE - utilizzare l'operatore logico di confronto "diverso da"
[6] - Funzione SE annidata
[7] - Funzione Logica SE annidata - due esempi di impostazione
[8] - Argomenti Funzione: La Finestra di dialogo della Funzione logica SE
[9] - Approfondimenti sulle Funzioni logiche - Sommario sezioni

La Funzione logica SE - introduzione e sintassi

La Funzione SE (nome in inglese della Funzione: IF)  valuta un test logico e restituisce due possibili valori a seconda che questo risulti VERO oppure FALSO.
La Funzione SE appartiene alla categoria delle Funzioni logiche di Excel e spesso viene applicata combinata ad altre Funzioni e assieme agli operatori di confronto E() O() e NON()

Sintassi della Funzione:

=SE(test;[se_vero];[se_falso]).
Nella quale:
test esprime un valore o una espressione logica che possa risultare vera o falsa. In questo argomento è possibile confrontare un numero, una data , un testo con un determinato operatore logico (Es.: uguale, maggiore; minore; diverso). Il test logico così espresso può pertanto restituire solo due argomentazioni:
se_vero rappresenta il valore da restituire quando il test logico risultasse soddisfatto
se_falso
rappresenta il valore da restituire quando il test logico NON risultasse soddisfatto
All'interno degli argomenti se_vero e se_falso della Funzione potranno essere indicati valori numerici, stringhe di testo (espresse fra doppi apici) oppure Formule.

Funzione SE di Excel: gli operatori logici di confronto

Il Test logico rappresenta l'elemento chiave della Funzione SE e deve essere correttamente individuato in modo tale che possa esprimere le due condizioni VERO o FALSO che serviranno per completare la sintassi dell'espressione.
Nell'impostare il test logico sono disponibili gli operatori di confronto, (schematizzati nella sottostante immagine).
Uguale a; Maggiore di; Minore di; Maggiore o uguale a; Minore o uguale a, Diverso da.
Dopo l'espressione del Test logico, nella successiva parte della Funzione, dovrà essere indicato cosa fare se il confronto con il test risulta VERO oppure FALSO.

La Funzione logica SE di Excel | Utilizzare gli operatori logici di confronto

Applicare la Funzione logica SE - due semplici esempi di applicazione

Primo esempio di applicazione della Funzione logica SE

Quale primo esempio consideriamo una Funzione logica SE che restituisca negli argomenti vero e falso un testo.
Nella sottostante tabella si vuole valutare l'idoneità di un gruppo di dipendenti a svolgere una mansione, rispetto alla quale è richiesta una esperienza lavorativa di almeno 10 anni di lavoro.
Nella cella C2 è stata inserita la seguente Funzione:
=SE(B2>=10;"idoneo";"non idoneo")
Il risultato restituito da questa impostazione sarà il testo "idoneo" se la persona ha almeno 10 anni di esperienza lavorativa, oppure "non idoneo" se il requisito non è soddisfatto.
:: Osservazione. Nel test logico della Funzione è stato inserito l'operatore di confronto ">=" (maggiore o uguale). Se fosse stato definito solo il simbolo di maggiore, il quinto dipendente dell'elenco che ha 10 anni di lavoro completati non sarebbe stato valutato come idoneo.

 

Secondo esempio di applicazione della Funzione logica SE

Valutiamo la stessa tabella precedente ma consideriamo di dover erogare un incentivo di 50 ero se il dipendete ha almeno 10 anni di anzianità lavorativa.
L'impostazione della Funzione SE è molto simile alla precedente.
Attenzione a non inserire il valore 50 o 0 fra doppi apici, altrimenti verrebbe inserito nel Foglio Excel in formato testo anzichè numerico!
La Funzione inserita nella cella C2 è la seguente =SE(B2>=10;50;0)

 

Applicare la Funzione SE -inserire Formule negli argomenti vero e falso

Nella definizione degli argomenti [se_vero] o [se_falso] della Funzione SE, oltre a testi e numeri, si possono inserire anche delle formule di calcolo.
Nell'esempio dell'immagine sotto raffigurata si vuole attribuire un incentivo pari al 4% del fatturato per le eventuali vendite mensili superiori ai 10.000 euro.
Pertanto se un venditore dovesse fatturare 12.000 euro, si dovrà calcolare il 4% di incentivo sui 2000 euro che hanno superato la soglia dei 10.000.
La Funzione inserita nella cella C3 è la seguente:
=SE(C3>10000;(c3-10000)*4%;0)

Nell'argomento se_vero della Funzione è stato inserita la formula per calcolare l'incentivo.
Nell'argomento se_falso della Funzione è stato inserito 0 (zero). Pertanto se il venditore non supera i 10.000 euro di fatturato, nella colonna incentivo verrà restituito il valore zero. (Vedi nell'immagine l'applicazione della Funzione sul Foglio Excel)

La Funzione logica SE di Excel | Inserire formule nelle Funzioni logiche di Excel 

Applicare la Funzione SE - utilizzare l'operatore logico di confronto "diverso da"

Nell'esempio sotto raffigurato, si vuole impostare una Funzione logica SE, che permetta di restituire come risultato un rimborso di 50 Euro a tutti coloro che non sono della città di Verona.
In questo caso è possibile impostare un criterio di esclusione che viene espresso dalle parentesi angolari aperta e chiusa. <>
La Funzione valuta se il valore contenuto nella cella C3 è diverso da "<>" Verona. Se VERO viene inserito il valore 50, se FALSO 0 (zero).
=SE(C3<>"Verona";50;0)

La Funzione logica SE di Excel | Applicare l'operatore logico diverso da

Funzione logica SE annidata

Quando sono necessarie più condizioni di valutazione, nell'argomento VERO o FALSO di una Funzione SE è possibile includere (annidare) una successiva Funzione SE che prenda in considerazione un ulteriore Test logico.
Pertanto più Funzioni SE nidificate permettono di testare più condizione e restituire più risultati.
In una Formula è possibile annidare fino a 64 livelli di funzioni.

Funzione Logica SE annidata - due esempi di impostazione

La nidificazione di una Funzione logica SE, a seconda del tipo di test, può essere inserita nel Vero o nel Falso della prima Funzione logica.
Per rilevare meglio questa differenza si propongono due esempi. Nel primo caso la nidificazione della Funzione SE è inserita (annidata) nell'argomento se_vero della prima funzione. Nel successivo esempio la nidificazione è inserita nell'argomento se_falso.

Primo esempio di Funzione logica SE annidata

Si vuole erogare un incentivo di 50 € o 100 € a seconda che il dipendente abbia almeno 10 anni oppure 20 anni di lavoro. Qualora il dipendente avesse meno di 10 anni lavorativi non è previsto l'incentivo.
Per spiegare passo per passo l'inserimento della Funzione risulta più facile costruirla in due distinti passaggi.
In primo luogo si definisce l'eventuale diritto o meno ad un incentivo, considerando solo la prima fascia dei 10 anni ovvero i 50 euro.
La Funzione da inserire nella cella C2 è la seguente =SE(B2>=10;50;0)
Una volta definito questo primo livello si passa ad annidare la seconda Funzione, nell'argomento Se_vero della prima.
Pertanto, quando risulta Vero che un dipendente ha almeno di 10 anni di lavoro, si va successivamente a verificare se è altrettanto Vero che ne ha abbia almeno 20.
La sintassi completa della Funzione è pertanto la seguente =SE(B2>=10;SE(B2>=20;100;50);0)
Per chiarire le due funzioni annidate, nell'immagine successiva, il testo scritto in nero rappresenta la prima Funzione SE.
La seconda funzione SE scritta in rosso è nidificata nell'argomento Se_vero della Prima Funzione logica.

Il risultato dell'impostazione di questa nidificazione potrà restituisce pertanto tre risultati. Se l'anzianità lavorativa è inferiore a 10, il risultato è 0 "zero". Se l'anzianità lavorativa è uguale o maggiore di 10, ma inferiore a 20. il risultato restituito è 50.
Infine, se l'anzianità lavorativa è maggiore o uguale a 20, il risultato sarà 100.
Nella successiva immagine è possibile vedere la Funzione SE applicata nel Foglio di lavoro di Excel.

:: Osservazione. La nidificazione è stata effettuata nel Vero della prima Funzione SE poichè chi ha più di 20 anni lavorativi è ovviamente Vero che ne abbia anche più di 10. Non sarebbe stato possibile nidificare nel Falso della prima Funzione SE, poichè nel falso della prima Funzione si vuole che venga restituito il valore zero per chi non ha requisiti per accedere all'incentivo.

 

Secondo esempio di Funzione logica SE annidata

In questo secondo caso si vuole erogare un incentivo in funzione dell'appartenenza o meno ad uno specifico settore di produzione.
Nell'esempio proposto in tabella si propone un incentivo di 50 € ai dipendenti del settore amministrazione, 100 € alla produzione. Non sono previsti incentivi per gli altri settori.
Anche in questo caso si può procedere con due distinti passaggi.
Nella cella C2 si imposta una prima Funzione che vada a definire il compenso per la sola amministrazione, impostando momentaneamente il valore zero per tutti gli altri settori.
=SE(B2="amministrazione";50;0)
Successivamente si va a sostituire lo zero che rappresenta tutti i settori esclusa l'amministrazione, con una seconda Funzione SE che vada a verificare se il valore contenuto nella cella B2 è uguale a "produzione". Nel vero di questa funzione va inserito 100, mentre se falso (cioè se non è ne amministrazione e ne produzione) il risultato sarà zero.

Anche in questo caso, per meglio comprendere come le due Funzioni sono state organizzate, la seconda Funzione SE nidificata nell'argomento falso della prima funzione logica è stata colorata in rosso. Ovvero, l'argomento Se_falso della prima funzione logica è rappresentato dalla seconda Funzione.
=SE(B2="amministrazione";50;SE(B2="produzione";100;0)).
Nella sottostante tabella è possibile prendere visione dell'applicazione della formula nel Foglio di lavoro di Excel.

 

Argomenti Funzione: La Finestra di dialogo della Funzione logica SE

Se imputare la corretta sintassi della Funzione SE può sembrare complicato, è possibile sfruttare l'opzione offerta dalla Finestra di dialogo Argomenti Funzione.
Molti utenti Office preferiscono utilizzare questa modalità di imputazione in Excel delle Funzioni.

La Funzione logica SE di Excel | Utilizzare argomenti Funzione

Quale esempio dell'applicazione della Funzione logica SE, attraverso la finestra di dialogo Argomenti Funzione, si considera l'esempio della restituzione di un giudizio Sufficiente od Insufficiente se il voto è maggiore o minore a 6. 
Una volta selezionata la cella D3, Per accedere ad Argomenti Funzione è sufficiente fare clic sul pulsante Fx della Barra della Formula e selezionare la Funzione SE fra le Funzioni Logiche o fra le Funzioni recenti.
Una volta individuata e selezionata la Funzione SE, si aprirà la finestra di dialogo Argomenti funzione (vedi immagine sottostante)

Nell'espressione del valore sufficiente o insufficiente all'interno della Finestra di dialogo Argomenti Funzione, non è necessario mettere il testo fra doppi apici, sarà automaticamente lo strumento Argomenti Funzione ad inserite le virgolette nella sintassi della Funzione.

La Funzione logica SE di Excel | Applicare la Funzione logica SE

:: Nota. Gli esempi riportati nella sezione, sono stati applicati alla Versione Excel 365, ma sono ugualmente applicabili anche alle versioni Excel 2007-2019

Approfondimenti sulle Funzioni logiche - Sommario sezioni

Le Funzioni Logiche (sintassi e applicazioni), sono state trattate in più sezioni del sito. Per aiutare chi desiderasse approfondire le proprie conoscenze su questa classe di Funzioni, viene proposto il seguente sommario riepilogativo.

Le Funzioni Logiche di Excel
    4.01 - Funzioni logiche: Funzione SE prima parte. Elementi di base e introduzioni alle Funzione Logiche
    4.02 - Funzioni logiche: Funzione SE seconda parte. Applicare i connettivi logici. Le Funzioni E; O; XOR e NON
    4.03 - Funzioni logiche: La Funzione PIÙ.SE
    4.04 - Funzioni logiche: Le Funzioni CONTA.SE; CONTA.PIÙ.SE per contare i valori definiti da uno o più criteri
    4.05 - Funzioni logiche: Le Funzioni SOMMA.SE; SOMMA.PIÙ.SE per sommare i valori definiti da uno o più criteri
    4.06 - Funzioni logiche: La Funzione SE.ERRORE e la correzione dei messaggi di errore di Excel
    4.07 - Funzioni logiche: La Funzione SWITCH
    4.08 - Esercitazioni ed approfondimenti: 12 esempi di applicazione della Funzione Logica SE

Indice Generale Argomenti: EXCEL

[Valter Borsato: ottobre - 2014 | Ultimo aggiornamento 30/12/2020]