www.valterborsato.it

La Funzioni logica PIÙ.SE

La nuova Funzione logica PIÙ.SE permette di impostare una serie di condizioni ed ottenere il risultato che corrisponde alla prima condizione che restituisce VERO.
La Funzione logica PIÙ.SE può essere applicata al posto della nidificazione di più Funzioni SE.
Qualora non venissero riscontrate condizioni VERE, la funzione PIÙ.SE restituisce il codice di errore #N/D.
La Funzione PIÙ.SE è disponibile dal dalla versione 2019 e nella versione 365.

Sintassi della Funzione PIÙ.SE

=PIÙ.SE(test_logico1; valore_se_vero1; [test_logico2; valore_se_vero2]; [test_logico3; valore_se_vero3];  ....…)
Nella quale:
test_logico1 (Argomento Obbligatorio) definizione di una condizione che restituisca VERO o FALSO.
valore_se_vero1 (Argomento Obbligatorio) Risultato (Valore) che deve essere restituito qualora il test_logico1 risultasse VERO.
test_logico2 (Argomento Facoltativo) definizione di una condizione che restituisca VERO o FALSO.
valore_se_vero2 (Argomento Facoltativo) Risultato (Valore) che deve essere restituito qualora il test_logico2 risultasse VERO.
test_logico3 (Argomento Facoltativo) definizione di una condizione che restituisca VERO o FALSO.
valore_se_vero3 (Argomento Facoltativo) Risultato (Valore) che deve essere restituito qualora il test_logico3 risultasse VERO.
.... etc, fino ad un massimo di 127 condizioni diverse.

Esempio di applicazione della Funzione logica PIÙ.SE

Nell'esempio proposto nell'immagine sottostante, nella cella B2, si vuole conoscere l'importo dell'incentivo spettante ad un dipendente del settore Produzione (cella A2).
Nell'intervallo di cella D2:E5 è presente una matrice dati con la descrizione di tutti gli importi spettanti settore per ogni settore.
Nella Cella B2 è stata inserita la seguente Funzione:
=PIÙ.SE(A2="Amministrazione";E2;A2="Direzione";E3;A2="Produzione";E4;A2="Vendite";E5)
Nella quale sono stati inseriti 4 diversi test logici che verificano l'eventuale appartenenza ad un settore.

La Funzioni logica PIÙ.SE: Impostazione della Funzione e sintassi

Qualora nella cella A2 venisse inserita le descrizione di un settore non previsto nell'elenco, la Funzione PIÙ.SE restituirebbe il codice di errore N/D!

La Funzioni logica PIÙ.SE: restituzione dell codice di errore

Considerazioni sull'aplicaizone della Funzione PIÙ.SE

La Funzione PIÙ.SE non aggiunge particolari vantaggi rispetto un utilizzo nidificato della classica Funzione SE.
Ma può rappresentare una valida alternativa, in termini di semplificazione, lettura dell'impostazione della sintassi, e soprattutto di non avere la necessità di descrivere e impostare un argomento FALSO.
Qualora la funzione PIÙ.SE non trovasse argomenti che soddisfano i test logici, come le Funzioni di ricerca e riferimento (quali ad esempio cerca.vert) restituisce il codice di errore #N/D (vedi immagine di cui sopra).
Se si volesse evitare la restituzione del codice di errore, è possibile nidificare la Funzione PIÙ.SE all'interno della Funzione SE.ERRORE
Esempio. =SE.ERRORE(PIÙ.SE(A2="Amministrazione";E2;A2="Direzione";E3;A2="Produzione";E4;A2="Vendite";E5);"")
::Approfondimento: Applicare la Funzione SE.ERRORE per gestire i messaggi di errore di Excel

Confronto sulle possibili alternativa alla Funzione PIÙ.SE

Come già anticipato la Funzione PIÙ.SE può sostituire un utilizzo nidificato della classica Funzione logica SE
Qualora la condizione fosse ricercare condizioni all'interno di una matrice (come nell'esempio precedente), non bisogna dimenticare che la Funzione CERCA.VERT può diventare una semplice e validissima alternativa all'impostazioni di una Funzione logica.
Nella sottostante immagine viene confrontata l'applicazione della Funzione PIÙ.SE con la Funzione SE (nidificata) e il CERCA.VERT
[CELLA C3] =PIÙ.SE(B3="Amminstrazione";F2;B3="Direzione";F3;B3="Produzione";F4;B3="Vendite";F5)
[CELLA C4] =SE(B3="Amministrazione";F2;SE(B3="Direzione";F3;SE(B3="Produzione";F4;SE(B3="Vendite";F5;"dato non disponibile"))))
[CELLA C5] =CERCA.VERT(B3;E2:F5;2;0)

La Funzioni logica PIÙ.SE: comparazione della Funzione  PIÙ.SE con altre Fuznioni

Indice Generale Argomenti: EXCEL

Sommario contenuti Excel sito www.valterborsato.ti

[Verona 02/9/2020]