www.valterborsato.it

La nuova funzione CERCA.X destinata a sostituire la Funzione Cerca Verticale.

In questa sezione viene trattata una introduzione all'utilizzo della Funzione Cerca x nuova e interessantissima Funzione di Excel.
Dalla fine di novembre 2019: CERCA.X è una Funzione disponibile (in versione beta) solo per chi partecipa al programma Office Insider.
Questa nuove funzione verrà ottimizzata nei prossimi mesi e successivamente ufficialmente rilasciata a tutti i partecipanti di Office Insider e a tutti gli abbonati a Office 365.

La presente sezione verrà aggiornata su tutte le novità che riguarderanno gli sviluppi della Funzione CERCA.X

:: ATTENZIONE. Office Insider per Windows è disponibile per coloro che possiedono un abbonamento a Office 365. per informazioni e iscrizioni a questo programma si rimanda alla pagina Office insider ITA

Introduzione alla Funzione CERCA.X, Limiti e problemi della Funzione Cerca Verticale

La Funzione Cerca.vert presenta tutta una serie di limiti che velocemente vengono sintetizzati nel sottostante elenco e ai quali la nuova Funzione CERCA X dovrebbe sopperire.
1) il Cerca verticale può cercare un valore solo (sottolineato solo) nella prima colonna di una matrice tabella.
2) Il cerca verticale, se si esclude il quarto argomento facoltativo [intervallo] opera una ricerca dei valori approssimativa e necessita che la prima colonna sia in ordine alfabetico crescente.
3) Il Cerca verticale non può avere valori doppi nella prima colonna di ricerca, nel caso fossero presenti dei valori duplicati cerca verticale restituisce il primo valore presente nell'elenco che soddisfa la ricerca.
4) Nel cerca verticale, qualora non si trovasse un codice non è possibile all'interno della funzione programmare un codice di errore.
5) Qualora si decidesse di effettuare una ricerca approssimativa cerca verticale restituisce sempre il valore minore precedente (per difetto) e non il valore successivo maggiore.
Per un approfondimento della funzione Cerca.vert si rimanda alla sezione la Funzione cerca verticale di Excel nella quale è presente anche un video di supporto.

La Funzione CERCA X

La Nuova funzione CERCA.X di Excel vorrebbe porre rimedio ad alcuni dei problemi di cui sopra e facilitare pertanto le operazioni di ricerca in Excel

Sintassi della Funzione

Nella sintassi della Funzione CERCA.X sono presenti 6 argomenti (3 argomenti obbligatori e 3 facoltativi)
=CERCA.X(Valore;matrice_ricerca;matrice_restituita;[se_non_trovato];[modalità_confronto];[modalità_ricerca])

Nella quale:
Valore: è il dato che deve essere ricercato nella matrice di ricerca;
matrice_ricerca: è la colonna nella quale ricercare il valore;
matrice_restituita è la colonna della matrice tabelle nella quale è presente il valore che si vuole venga restituito;
[se non trovato] in questo primo argomento facoltativo è possibile definire un codice di errore quale ad esempio "codice non trovato" sensa dover ricorre alla funzione se.errore;
[modalità di confronto] in questo secondo argomento facoltativo è possibile programmare i seguenti codici 0 = corrispondenza esatta; -1 corrispondenza esatta o elemento successivo più piccolo; 1 = corrispondenza esatta o numero successivo più grande; 2 = corrispondenza carattere jolly;
[modalità_ricerca] in questo terzo e ultimo argomento facoltativo è possibile definire attraverso codici le seguenti direzioni di ricerca: 1 = ricerca dal primo all'ultimo dei valori presenti nell'elenco; -1 ricerca dall'ultimo al primo dei valori presenti nell'elenco; 2 Ricerca binaria in ordine crescente; -2 ricerca binaria in ordine decrescente;

Appena in una cella si imputa la funzione CERCA X viene proposta la seguente sintassi.

Sintassi della Funzione CERCA.X

Primo esempio di applicazione della Funzione CERCA.X

In questo primo esempio concentriamo l'attenzione sui soli 3 argomenti obbligatori della funzione CERCA.X
Al contrario del cerca verticale, (per il quale questa opzione non sarebbe possibile), si vuole cercare un valore presente nella seconda colonna di una matrice e ottenere la restituzione del valore corrispondente presente nella prima colonna. (vedi immagine sottostante)
Il codice che si vuole cercare (il valore sn2) è contenuto nella cella g3; e si vuole la restituzione del valore presente nella prima colonna della matrice (la categoria del prodotto).
La Funzione inserita sarà la seguente =CERCA.X(G3;C3:C15;B3;B15)
nella quale G3 è la cella che contiene il codice del prodotto nel nostro caso sn2;
C3:C15 è la colonna nella quale cercare il codice;
ed infine B3:B15 e la colonna che contiene il nome della categoria dei prodotto che vogliamo venga restituita.

La Funzione CERCA.X | Esempio di ricerca utilizzando i soli argomenti obbligatori della Funzione

Nella tabella di cui sopra, qualora volessimo la restituzione del valore presente nella terza colonna (ovvero il modello) la funzione andrebbe modificata in:
=CERCA.X(G3;C3:C15;D3:D15)
ovviamente le due funzioni CERCA.X potrebbero anche essere concatenate per avere in una unica cella la restituzione sia della categoria del prodotto sia del modello. (vedi immagine sottostante)
=CERCA.X(G3;C3:C15;B3:B15)&" "&CERCA.X(G3;C3:C15;D3:D15)

La Funzione CERCA.X | Concatenare due Funzioni

Per approfondimento sulle concatenazioni si rimanda a le concatenazioni di testo in Excel

Secondo esempio di applicazione della Funzione CERCA.X
Gestire il codice di errore #N/D

All'interno della sintassi stessa della Funzione CERCA.X, senza ricorrere alla Funzione SE.ERRORE, è possibile definire un codice di errore alternativo al noto #N/D
:: ATTENZIONE il codice #N/D viene restituito anche nel caso della Funzione CERCA.X qualora non venisse definito l'argomenti facoltativo [se_non _trovato]
Nell'esempio illustrato nell'immagine sottostate, viene cercato un codice (sn3) non presente nella matrice C3:C15. Come quarto argomento fra doppi apici è stato inserito il testo "codice inesistente"
=CERCA.X(G3;C3:C15;B3:B15;"codice inesistente")

La Funzione CERCA.X | gestire il codice di errore

Terzo esempio di applicazione della Funzione CERCA.X
Gestire una ricerca per approssimazione

Seppur meno frequenti delle ricerche per corrispondenza esatta, a volte può rendersi necessaria impostare un ricerca per approssimazione.

:: ATTENZIONE. Contrariamente al cerca verticale, con la nuova Funzione CERCA.X, qualora non venisse impostato il 5 argomento la ricerca che viene effettuata è quella per corrispondenza esatta e non approssimativa.

Esempio. Nell'immagine sottostante, non essendo presente il codice sn3 nella tabella si vuole la restituzione del valore vicino più piccolo (sn2). per impostare questa ricerca nel 5 argomento della Funzione CERCA.X deve essere impostato il codice -1

=CERCA.X(G3;C3:C15;B3:B15;"codice inesistente";-1)

La Funzione CERCA.X | impostare una ricerca per approssimazione

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT