www.valterborsato.it

Le Funzioni SOMMA.SE e SOMMA.PIÙ.SE per sommare i valori definiti da uno o più criteri

La Funzione SOMMA SE permette di sommare i valori presenti in un intervallo di celle che soddisfano un determinato criterio logico.
La Funzione SOMMA PIÙ SE permette di sommare i valori presenti in un intervallo che soddisfa più criteri.
la Funzioni SOMMA.PIÙ.SE è disponibile dalla versione 2007 di Excel. Entrambe le Funzioni appartengono alla categoria delle Funzioni Matematiche.

La Funzione SOMMA.SE

La sintassi della Funzione è la seguente:
=SOMMA.SE(intervallo;criterio;[int_somma])
nella quale:
intervallo
: è l’intervallo nelle quali cercare i valori.
criterio
: definisce la condizione del valore da ricercare nell'intervallo;  L'impostazione del criterio è un argomento molto flessibili in quanto possono essere applicati operatori logici, riferimenti a celle, funzioni, ed utilizzare i caratteri * e ?
Int_somma
: argomento facoltativo. Definisce le celle che verranno sommate se si realizza il vero della condizione definita nel criterio. Qualora l'argomento venisse omesso verranno calcolate i valori presenti nella colonna sulla quale è stato definito il criterio.

Esempio di applicazione della Funzione SOMMA.SE

Nella tabella illustrata nella sottostante immagine, si consideri la necessità di calcolare il fatturato complessivo di un solo venditore (ad esempio Rossi).
Il riferimento al venditore potrà essere indicato facendo riferimento ad una cella entro cui è imputato il nome oppure inserendo il nome stesso del venditore fra doppi apici all'interno della formula.
E' pertanto possibile esprimere la Funzione nel seguente modo: =SOMMA.SE(C:C;"Rossi";F:F)  
Ovvero: Intervallo tutta la colonna C:C; criterio "Rossi" int_somma tutta la colonna F:F

::Nota. Nel definire l'area dell'intervallo dei criteri e dell'intervallo sa sommare è possibile fare riferimento all'intera colonna del foglio di lavoro indicando rispettivamente con C:C e F:F le intere colonne C e F del foglio di lavoro.

Excel | La funzione SOMMA.SE - Applicare somma se

Utilizzare solo due argomenti nella Funzione SOMMA.SE

Come espresso dalla sintassi: =SOMMA.SE(intervallo;criterio;[int_somma]) il terzo argomento della Funzione, essendo indicato fra parentesi quadrata  [int_somma],  è un argomento facoltativo.
Nel caso in cui la colonna nella quale verificare il criterio sia la stessa da sommare è possibile utilizzare solo i primi due argomenti della Funzione SOMMA.SE

Esempio immagine sottostante.
Si vogliono sommare solo i numeri positivi, pertanto si imposta il criterio che i valori contenuti nell'intervallo delle celle B2:B6 siano maggiori di zero.
=SOMMA.SE(B2:B6;">0")
:: Attenzione. Il criterio maggiore di zero ">0"  all'interno della Funzione deve essere espresso fra doppi apici.

 La funzione SOMMA.SE - Esempio di applicazione

La Funzione SOMMA.PIÙ.SE

La Funzione SOMMA.PIÙ.SE permette di calcolare i valori contenuti nelle celle di un determinato intervallo che soddisfano più criteri.

La sintassi della formula è la seguente:
=SOMMA.PIÙ.SE(int.somma;int.criteri1;criteri1; int.criteri2;criteri2… )

Il primo operatore che va inserito nella Funzione è l'intervallo da sommare (int_somma). Successivamente vanno indicati il primo intervallo di criteri e il primo criterio; il secondo intervallo di criteri e il secondo criterio e così a seguire ....

Esempio se si volesse sommare il fatturato del venditore Bianchi nella sola Regione Lombardia la formula sarebbe la seguente:
=SOMMA.PIÙ.SE(F:F;C:C;"Bianchi";D:D;"Lombardia")

Excel | La Funzione SOMMA.PIÙ.SE 

Applicare i caratteri jolly nei criteri di somma

::Approfondimento.  Le funzioni SOMMA.SE; SOMMA.PIÙ.SE nell'impostazione dei criteri posso utilizzare i caratteri jolly.
I caratteri Jolly utilizzabili sono l'asterisco e il punto di domanda. L'asterisco sostituisce e corrisponde ad un numero qualsiasi di caratteri. È possibile usare l'asterisco in qualsiasi posizione (prima o dopo) una stringa di caratteri. Il punto di domanda, corrisponde ad una qualsiasi lettera all'interno di una stringa di testo.
Esempio: 
Ros* potrebbe considerare qualsiasi venditore il cui nome contiene la stringa di testo "ros"
R?ssi invece potrebbe restituire sia Rossi sia Russo.


E' possibile scaricare il file Excel contente gli esempi sull'utilizzo delle funzioni SOMMA.SE; SOMMA.PIÙ.SE.

Argomenti correlati

Le Funzioni Logiche di Excel
    - Funzioni logiche: Funzione SE prima parte. La Funzione SE (sintassi e operatori logici di confronto)
    - Funzioni logiche: Funzione SE seconda parte. Applicare gli operatori connettivi. Le Funzioni E; O; NON
    - Funzioni logiche: Utilizzare le Funzioni SOMMA.SE; SOMMA.PIÙ.SE per sommare i valori definiti da uno o più criteri
    - Funzioni logiche: Utilizzare le Funzioni CONTA.SE; CONTA.PIÙ.SE per contare i valori definiti da uno o più criteri
    - Funzioni logiche: La Funzione SE.ERRORE e la correzione dei messaggi di errore di Excel
    - Esercitazioni ed esempi: Dodici esempi pratici di applicazione della Funzione logica SE

Indice Generale Argomenti: EXCEL - WORD & POWERPOINT